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SAP2000 Application Example: 

Underground 
Water Tank 

3 
ตัวอย่างนี้จะเป็นการวิเคราะห์และออกแบบถังเก็บน้้าใต้ดินคอนกรีตเสริมเหล็กรองรับด้วยเสาเข็ม
เจาะมีแบบแปลนและแบบด้านข้าง ดังแสดงในรูป 
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ข้อมูลดิน : 

หน่วยน้้าหนักดินแห้ง dry   = 1.9 t/m3 

หน่วยน้้าหนักดินเปียก wet = 2.2 t/m3 

มุมเสียดทานของดิน  = 20 องศา 

แรงกดที่ผิวดิน (surcharge)    = 1.0 t/m2 

 เริ่มต้นโปรแกรม SAP2000 เปลี่ยนหน่วยเป็นหน่วย Kgf, m, C 

 กด Ctrl+N เริ่มต้นโมเดลใหม่ เลือกใช้ Grid Only เพ่ือสร้างเฉพาะเส้นกริดเท่านั้น 
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 ใส่ข้อมูลเส้นกริดทิศทาง X, Y และ Z ดังในรูป 
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 เมื่อคลิก OK เส้นกริดจะถูกสร้างข้ึน ปรับหน้าต่างมุมมอง X-Z Plane @ Z=0 ดังในรูป  

 

 สั่งเมนู File > Save บันทึกไฟล์ตั้งชื่อว่า AX03 UnderG WTank.sdb 

ก าหนดคุณสมบัติวสัด ุ  

 เราจะก้าหนดวัสดุสองชนิดคือเหล็กเสริมและคอนกรีต สั่งเมนู Define > Materials… หรือคลิก

ปุ่ม    หน้าต่างวัสดุจะแสดงขึ้นมา โดยมีสองรายการที่ติดมากับโปรแกรมคือ 4000Psi 
ส้าหรับคอนกรีต และ A992Fy50 ส้าหรับเหล็กรูปพรรณ 

 เลือกรายการ 4000Psi แล้วคลิกปุ่ม Modify/Show Material เพ่ือแก้ไข 

  

 ปรับเปลี่ยนข้อมูลเป็นคอนกรีต Fc240 ดังในรูป 
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 เพ่ิมวัสดุใหม่คือเหล็กเส้นเสริมคอนกรีต (Rebar) คลิกปุ่ม Add New Material  

 

 หน้าต่าง Quick Material Definition จะแสดงขึ้นมาให้เลือกเหล็กตามมาตรฐานที่ใกล้เคียงคือ 
ASTM A615 

 



SAP2000 : Application Examples : Underground Water Tank By  Dr.Mongkol  JIRAWACHARADET 41 

 

 เมื่อมีรายการเพ่ิมเข้ามา ให้กดปุ่ม Mofify/Show Material เพ่ือแก้ไขข้อมูล 

 

 ใส่ข้อมูลเหล็กเสริมคอนกรีต SD40 ซึ่งมีคุณสมบัติ ดังนี้ 

 

เมื่อใส่ข้อมูลเสร็จแล้วคลิก OK แล้ว เราจะมีรายการวัสดุคือ 
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สร้างจุดรองรับ Supports 

 คลิกปุ่ม  เพ่ือวาดจุด โดยตีกรอบคลุมจุดตัดกริดทั้งหมด 

 

 ตีกรอบเลือกจุดทั้งหมด สั่งเมนู Assign > Joint > Restraints… เลือกแบบ Pinned 

 

จุดรองรับจะถูกสร้างขึ้นตามจุดตัดกริดดังในรูป 
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พื้นถังน้ า  

 สั่งเมนู Define > Section Properties > Area Sections คลิกรายการ ASEC1 กดปุ่ม 
Modify/Show Section… 

 

 เปลี่ยนชื่อเป็น SLAB เลือกเป็นแบบ Shell-Thick ความหนา 1 m 

 

 คลิกปุ่ม    เลือกหน้าตัด SLAB คลิกวาดตีกรอบคลุมทั้งหมด 
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 คลิกเลือกพ้ืนที่วาด สั่งเมนู Edit > Edit Areas > Expand/Shrink Areas สั่งขยายออกทุกด้าน
เป็นระยะ 1 m 

 

พ้ืนจะขยายออกทุกด้าน 1 m ดังในรูป 
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 คลิกเลือกพ้ืน สั่งเมนู Assign > Area > Automatic Area Mess เพ่ือก้าหนดการแบ่งพ้ืนย่อย 

 

 ลองสั่งรันโดยกด F5 ดูผลจากน้้าหนักของพ้ืน DEAD คลิกหน้าต่าง 3-D View กดปุ่ม  
เลือก Shells ก้าหนดค่าดังในรูป 
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น้ าหนักน้ าบนพ้ืนถัง  

ถังน้้ามีความสูง 3 เมตร น้้าหนักบรรทุกของน้้าบนพื้นถัง  =  w h  =  1.0 x 3.0  =  3.0 t/m2 

 คลิกปุ่ม  ปลดล็อคโมเดล สั่งเมนู Define > Load Patterns สร้างกรณีบรรทุก WATER 

 

 คลิกเลือกพ้ืน สั่งเมนู Edit > Edit Areas > Divide Areas เลือกแบ่งพ้ืนตามจุดตัดกริด 
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พ้ืนจะถูกแบ่งออกตามจุดตัดกริด 

 

 คลิกเลือกพ้ืนภายในโดยตีกรอบภายในจากมุมขวาบนลงซ้ายล่างดังในรูป 

 

 สั่งเมนู Assign > Area Loads > Uniform (Shell) ใส่น้้าหนักน้้า WATER = 3000 kg/m2 

 

 กด Ctrl+A เลือกทั้งหมด สั่งเมนู Assign > Areas > Automatic Area Mesh เพ่ือแบ่งพ้ืนย่อย 
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 ลองสั่งรันโดยกด F5 ดูผลจากน้้าหนักของพ้ืน WATER คลิกหน้าต่าง 3-D View กดปุ่ม  
เลือก Shells ก้าหนดค่าเช่นเดิม  

 สั่งเมนู File > Save As ตั้งชื่อใหม่เป็น AX03 UnderG WTank2.sdb 

 

ผนังด้านข้าง  

 คลิกปุ่ม  ปลดล็อคโมเดล สั่งเมนู 
Define > Section Properties > Area 
Sections… คลิกปุ่ม Add New Section… 
เพ่ือสร้างหน้าตัดผนัง WALL  
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 คลิกหน้าต่างสองมิติแล้วกดปุ่ม  แล้วกดปุ่ม  จนได้มุมมอง X-Z Plane @ Y= 0 

 คลิกปุ่ม    เลือกหน้าตัด WALL แล้ววาดผนังดังในรูป 

 

 คลิกเลือกผนังที่วาด กด Ctrl+R เพ่ือท้าซ้้าโดยใช้ระยะ dy = 9 จะได้ 

 

 คลิกหน้าต่างสองมิติแล้วกดปุ่ม  แล้วกดปุ่ม  จนได้มุมมอง Y-Z Plane @ X= 0 

 คลิกปุ่ม    เลือกหน้าตัด WALL แล้ววาดผนังดังในรูป 

 เลือกผนังที่วาดแล้วกด Ctrl+R ท้าซ้้าโดยใช้ระยะ dx = 18 
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 คลิกปุ่ม    เลือกให้แสดง Area > Local Axes เพ่ือดูแกนเฉพาะที่ของผนัง 

 

จะเห็นว่าแกน 3 (ลูกศรสีฟ้า) ของผนังทั้ง 4 ด้านมีทิศทางดังในรูป 

X

Y

3

3

33

 

เพ่ือความสะดวกในการใส่แรงดันน้้าและแรงดันดิน เราจะเปลี่ยนทิศแกน 3 ของทุกผนังเป็นพุ่ง
ออกท้ังหมด 
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 ในหน้าต่าง 3-D คลิกเลือกผนังด้านซ้ายและผนังด้านบน สั่งเมนู Assign > Area > Reverse 
Local 3 แกนเฉพาะที่ของผนังจะเปลี่ยนเป็นดังในรูป 

 

 สั่งเมนู File > Save As ตั้งชื่อใหม่เป็น AX03 UnderG WTank3.sdb 

แรงดันน้ าบนผนังด้านข้าง Water Pressure 

วิธีที่ 1 : Uniform Surface Pressure 

แรงดันน้้ามีการกระจายเป็นรูปสามเหลี่ยมตามสูตร w h ดังในรูปด้านซ้าย แต่ใน SAP2000 มีให้ใส่
เฉพาะแรงดันสม่้าเสมอ ดังนั้นถ้าท้าแบบง่ายก็อาจค้านวณเป็นค่าแรงดันเทียบเท่าดังในรูปด้านขวา 

3 m

3 t/m
2

3 m

1.5 t/m
2

 

 คลิกเลือกผนังทั่งหมด หรือ สั่งเมนู Select > Select > Properties > Area Sections เลือก 
WALL แล้วกด Ctrl+Shift+G ตั้งชื่อกลุ่มเป็น WALL 

 กด Ctrl+G เลือกกลุ่ม WALL สั่งเมนู Assign > Area > Automatic Area Mess แบ่งพ้ืนย่อย
เป็นขนาด 1 m เช่นเดียวกับพ้ืน 
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 กด Ctrl+G เลือก WALL สั่งเมนู Assign > Area Loads > Surface Pressure 

 

 ลองสั่งรันโดยกด F5 ดูผลจากน้้าหนักของพ้ืน WATER คลิกหน้าต่าง 3-D View กดปุ่ม  
เลือก Shells เลือก Resultant Force > Mmax 

 

วิธีที่ 2 : Surface Pressure by Joint Pattern 

เราสามารถก้าหนดรูปแบบการกระจายแรงดันโดยการใช้ “รูปแบบจุดต่อ (Joint Pattern)” ซึ่ง
อาจจะยุ่งยากกว่าวิธีแรกแต่จะมีความใกล้เคียงกับความเป็นจริงมากกว่า 

 สั่งเมนู File > Save As ตั้งชื่อใหม่เป็น AX03 UnderG WTank4.sdb 

 กด Ctrl+G เลือกกลุ่ม WALL สั่งเมนู Assign > Area > Automatic Area Mess เลือก No 
Auto Meshing เพ่ือยกเลิกการแบ่งพ้ืนย่อยอัตโนมัติ 

 กด Ctrl+G เลือก WALL สั่งเมนู Assign > Area Loads > Surface Pressure เลือก Delete 
Existing Loads เพ่ือลบน้้าหนักเดิมออก 



SAP2000 : Application Examples : Underground Water Tank By  Dr.Mongkol  JIRAWACHARADET 53 

 

 

 เสร็จแล้วลองคลิกขวาที่ผนัง ตรวจดูในแถบ Assignments > Automatic Area Mesh = 
None และในแถบ Loads จะไม่มีข้อมูล 

 กด Ctrl+G เลือก Wall สั่งเมนู Edit > Edit Areas > Divide Areas แบ่งเป็นขนาด 1 m 

 

ผนังทั้งหมดจะถูกแบ่งย่อยเป็นขนาด 1 m ดังในรูปข้างล่าง 
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 สั่งเมนู Define > Joint Patterns… กด Add New Pattern Name ตั้งชื่อว่า WaterP 

 

 คลิกหน้าต่างสองมิติ สั่งเมนู View > Set 3D View เลือก XY ให้แสดงรูปแปลน 

 

 ตีกรอบเลือกผนังทั้ง 4 ด้านทีละผนังดังในรูป 
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 สั่งเมนู Assign > Joint Patterns เลือก WaterP แบบ Z Coordinate at Zero Pressure 
แล้วใส่ค่าระดับความสูง Z ที่ระดับผิวน้้าคือ 3 m และหน่วยน้้าหนักน้้าคือ 1000 kg/m3 
ข้อจ้ากัด Zero Neg หมายถึงไม่มีค่าลบ 

 

 คลิกมุมมอง 3-D View สั่งเมนู Display > Show Misc Assigns > Joints… เลือกให้แสดง 
Joint Patterns > WaterP 
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 เมื่อซูมขยายในมุมมองสามมิติจะค่าแรงดันกระจายตามจุดต่อดังในรูป 

 

 กด Ctrl+G เลือก Wall สั่งเมนู Assign > Area Loads > Surface Pressure เลือกกรณี
บรรทุก Water และรูปแบบจุดต่อ WaterP ดังในรูป 

 

 คลิกหน้าต่าง 3-D View สั่งเมนู Display > Show Load Assigns > Area… เลือกให้แสดง
แรงดันน้้าโดยก้าหนดดังในรูป 
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จะสังเกตแรงดันบนผนังทั้ง 4 ด้านมีทิศพุ่งออกและมีขนาดเพ่ิมข้ึนจากบนลงล่าง 

 

 ลองสั่งรันโดยกด F5 ดูผลจากน้้าหนักของพ้ืน WATER คลิกหน้าต่าง 3-D View กดปุ่ม  
เลือก Shells เลือก Resultant Force > Mmax 

 

แรงดันดินบนผนังด้านข้าง Earth Pressure 

แรงดันดินบนผนังด้านข้างจากดินภายนอกแบ่งเป็นสองส่วนคือ ph1 แรงดันดินจากน้้าหนักบรรทุก
กดทับ (surcharge) บนผิวดินมีค่าคงที่, ph2 แรงดันจากเนื้อดิน และ pw แรงดันน้้าซึ่งเพ่ิมขึ้นตาม
ความลึกกระจายเป็นรูปสามเหลี่ยม ดังแสดงในรูป 
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3 m

ph1ph2pw

 

การค้านวณแรงดันดินโดยใช้สูตรอย่างง่ายท้าได้โดยใช้ค่าสัมประสิทธิ์ Ka ซึ่งค้านวณจากค่ามุมเสียด
ทานของดิน 

o

a o

1 sin 1 sin20
K 0.4903

1 sin 1 sin20

  
  

  
 

ph1  =  Ka x surcharge  =  0.4903 x 1000  =  490  kg/m2 

ph2  =  Ka ’ h  =  0.4903 x (2200–1000) h  =  588 h  kg/m2 

 pw  =  w h  =  1000 h  kg/m2 

ph2 + pw  =  1588 h kg/m2 

 สั่งเมนู File > Save As ตั้งชื่อใหม่เป็น AX03 UnderG WTank5.sdb 

 สั่งเมนู Define > Load Patterns สร้างกรณีบรรทุก SOIL 

 

 สั่งเมนู Define > Joint Patterns… กด Add 
New Pattern Name ตั้งชื่อว่า SoilP 

 คลิกหน้าต่างสองมิติ สั่งเมนู View > Set 3D 
View เลือก XY ให้แสดงรูปแปลน 

 ตีกรอบเลือกผนังทั้ง 4 ด้านทีละผนังเช่นเดิมเพ่ือ
เลือกจุดต่อท้ังหมดบนผนัง 
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 สั่งเมนู Assign > Joint Patterns เลือก SoilP แบบ Z Coordinate at Zero Pressure แล้ว

ใส่ค่าระดับความสูง Z ที่ระดับผิวน้้าคือ 3 m และหน่วยน้้าหนักดินคือ 1588 kg/m3 ข้อจ้ากัด 
Zero Neg หมายถึงไม่มีค่าลบ และใช้ surcharge เพ่ิมอีก 1000 kg/m2 

 

 คลิกมุมมอง 3-D View สั่งเมนู Display > Show Misc Assigns > Joints… เลือกให้แสดง 
Joint Patterns > SoilP 

 

 

 



SAP2000 : Application Examples : Underground Water Tank By  Dr.Mongkol  JIRAWACHARADET 60 

 

 

 กด Ctrl+G เลือก Wall สั่งเมนู Assign > Area Loads > Surface Pressure เลือกกรณี
บรรทุก SOIL และรูปแบบจุดต่อ SoilP ดังในรูป 

 

จะสังเกตแรงดันบนผนังทั้ง 4 ด้านมีทิศพุ่งเข้าและมีขนาดเพ่ิมข้ึนจากบนลงล่าง 
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 ลองสั่งรันโดยกด F5 ดูผลจากน้้าหนักของพ้ืน SOIL คลิกหน้าต่าง 3-D View กดปุ่ม  
เลือก Shells เลือก Resultant Force > Mmax 

 

สภาวะการออกแบบถังน้ าใต้ดิน Design Conditions 

การออกแบบถังน้้าใต้ดินจะพิจารณาออกแบบเพ่ือรับน้้าหนักบรรทุกใน 2 สภาวะคือ กรณีที่มีน้้าเต็ม
ถังมีแรงดันน้้าแต่ไม่มีแรงดันดินโดยรอบ และกรณีที่ไม่มีน้้าในถังแต่มีแรงดันดินโดยรอบ 

pw

pw pw

pw

Water Pressure

ph

ph ph

ph

Soil Pressure  

โดยก้าหนดเป็นกรณีบรรทุกร่วม (Load Combination) ส้าหรับการออกแบบโดยวิธีหน่วยแรงใช้
งาน (Working Stress Design, WSD) และวิธีก้าลัง (Strength Design Method, SDM) คือ 

WSD1  =  DEAD + WATER  SDM1  =  1.4 DEAD + 1.7 WATER 

WSD2  =  DEAD + SOIL  SDM2  =  1.4 DEAD + 1.7 SOIL 
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 สั่งเมนู Define > Load Combinations… คลิกปุ่ม Add New Combo เพ่ือสร้างกรณีบรรทุก

ร่วมใหม่ ตั้งชื่อแล้วเลือกกรณีบรรทุกและก้าหนดค่าแฟกเตอร์ เช่นกรณี WSD1 ดังในรูป 

 

 เมื่อสร้างจนครบทุกกรณีจะได้รายการดังในรูป 

 

 สั่งรันการวิเคราะห์โดยกด F5  
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ผลการวิเคราะห์เพื่อการออกแบบ Analysis Results for Designs 

การพิจารณาแรงภายในผนังเพ่ือน้าไปออกแบบจะอ้างอิง
ตามทิศทางของแกนเฉพาะที่ของผนังคือแกน 1, 2 และ 3  

โดยที่แกน 3 จะชี้ออกนอกระนาบผนัง แกน 1 จะอยู่ใน
แนวราบในระนาบผนัง และแกน 2 จะอยู่ในแนวดิ่งใน
ระนาบผนัง 

เหล็กเสริมทางตั้ง จะพิจารณาจากโมเมนต์ในแนวนอนคือ M11 ดังแสดงในรูป 

H

w H

M11

 

 คลิกหน้าต่าง 3-D View กดปุ่ม    เลือก Shells เลือกกรณีบรรทุก WSD1 ให้แสดง 
Resultant Force > M11 

 

X

Z

Y

1

2

3
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 คลิกหน้าต่างสองมิติ กดปุ่ม    ให้แสดงมุมมอง X-Z Plane @ Y=0 

 กดปุ่ม    เลือก Shells เลือกกรณีบรรทุก WSD1 ให้แสดง Resultant Force > M11 

 

 เลื่อนตัวชี้ไปตามพ้ืนที่บนผนังเพ่ือหาค่ามากที่สุด คลิกขวาเพ่ือให้แสดงรูปขยายของผนังย่อย 

 

จะได้ค่าโมเมนต์มากที่สุดคือ 919 Kgf-m/m 

 ท้าเช่นเดิมส้าหรับกรณีบรรทุก WSD2, SDM1 และ SDM2 จะได้ 

 M11 (Kgf-m/m) 

WSD1 919 

WSD2 -2,358 

SDM1 1,562 

SDM2 -4,009 
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ผลของฝาถัง Effect of Roof Slab 

ถังน้้าบางแบบจะมีฝาถังซึ่งจะมีส่วนช่วยในการลดแรงในผนังได้ ซึ่งผู้ออกแบบจะระบุให้หล่อฝาถัง
ก่อนแล้วจึงค่อยกลบดินด้านข้าง ทั้งนี้ก็เพ่ือหลีกเลี่ยงแรงในผนังที่มากเกินกว่าที่ได้ออกแบบไว้ 

 สั่งเมนู File > Save As ตั้งชื่อใหม่เป็น AX03 UnderG WTank6.sdb 

 สั่งเมนู Define > Section Properties > Area Sections… คลิกปุ่ม Add New Section เพ่ือ
สร้างหน้าตัดใหม่ ตั้งชื่อว่า TSLAB ก้าหนดค่าดังในรูป 

 

 คลิกหน้าต่างสองมิติ กดปุ่ม    และ    ให้แสดงมุมมอง X-Y Plane @ Z=3 

 คลิกปุ่ม    เลือกหน้าตัด TSLAB แล้วคลิกวาดพื้นโดยตีกรอบคลุมทั้งหมด 

 คลิกเลือกพ้ืนที่วาด สั่งเมนู Assign > Area > Automatic Area Mesh ก้าหนดขนาดพ้ืนย่อย 
1 m เช่นเดียวกับพ้ืนด้านล่าง และผนังด้านข้าง 
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 สั่งรันการวิเคราะห์โดยกด F5 แล้วดูผลโดยคลิกหน้าต่าง 3-D View กดปุ่ม    เลือก 
Shells ให้แสดง Resultant Force > MMAX ของกรณีบรรทุก WATER และ SOIL จะได้ 
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 คลิกหน้าต่างสองมิติ กดปุ่ม    ให้แสดงมุมมอง X-Z Plane @ Y=0 

 กดปุ่ม    เลือก Shells เลือกกรณีบรรทุก WSD1 ให้แสดง Resultant Force > M11 

 

 ท้าเช่นเดิมเพื่อหาโมเมนต์มากที่สุดส้าหรับกรณีบรรทุก WSD2, SDM1 และ SDM2 จะได้ 

 M11 (Kgf-m/m) 

WSD1 704 

WSD2 -839 

SDM1 1,086 

SDM2 -1,193 

จะเห็นว่ามีค่าลดมากเมื่อเทียบกับกรณีที่ไม่มีฝาถัง 

ออกแบบเหล็กเสริมทางตั้งโดยวิธีหน่วยแรงใช้งาน WSD 

ก้าหนด fc  =  65 ksc  ตามกฎกระทรวง 

  fs  =  0.5fy  =  1500 ksc 

  n  =  Es/Ec  =  8.54 

  k  =  1/(1+fs/nfc)  =  0.27 

  j  =  1 – k/3  =  0.91 

  R  =  (1/2) fc k j  =  7.985 ksc 

 Mc  =  R b d2  =  7.985 x 1.0 x 252  =  4,991 kg-m  >  839 kg-m  OK 
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ค้านวณปริมาณเหล็กเสริมแนวตั้งที่ต้องการ 

 As  =  M / ( fs j d )  =  83,900/(1,500x0.91x25)  =  2.46 cm2 / m 

 As,min  =  0.0015bh  =  0.0015x100x30  =  4.5 cm2 / m ควบคุม 

ใช้เหล็ก DB12 (As1 = 1.131 cm2)  

 ระยะห่างที่ต้องการ  s  =  As1/As,min  =  1.131/4.5  =  0.251 m 

ใช้เหล็กเสริมทางตั้ง DB12 @ 0.25 m 

ออกแบบเหล็กเสริมทางตั้งโดยวิธีก าลัง SDM 

ก้าหนด f’c  =  240 ksc  ดังนั้น  1 = 0.85 

 fy  =  4,000 ksc  (เหล็ก SD40) 

 b  =  0.85 (0.85x240)/4,000 x 6,120/(6,120+4,000)  =  0.0262 

 max  =  0.75b  =  0.0197 

 Rn  =  Mu/bd2  =  119,300/(0.9x100x252)  =  2.12 ksc 

 c u

y c

0.85f 2R
1 1

f 0.85f

 
    

  

  =  0.00053  <  max   OK 

 As  =  bd  =  0.0053x100x25  =  1.33 cm2/m  <  As,min   Use As,min 

ใช้เหล็กเสริมทางตั้ง DB12 @ 0.25 m 

 


