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 %	�&���	' Customize  !	"�	� CAD�� 
�"(�)*&�+� (,+�-��
%���%	�&���	'%!)��-�),�./*
0���(�1�
 !	"�	�	+�'2
��	"���1 Toolbars 0	��&	��
%���")* Toolbar 
0�� 
�����34*�56��-'2
 

� ��	(,3
 Program’s preference 
� ��	 Customize %���")* Toolbars 
� ��	 Customize ����	78 
� ��	&	��
�9�&,�
-���+�&9�0	,�
��:6�:7��� Command line 
� ��	&	��
")*
�� Scripts 
� ��	
�� !	"�	� Add-on �,� !	"�	� CAD�� 
� ��	
��(,+ Digitizer &9�0	,�%)���
���9�&,�
")*��	 Calibrated drawing 

 
0,+1��
�����3 

��	(,3
")*��	%!)��-���!�,� 
��	 Customize %��� 
��	 Customize toolbars 
��	 Customize ����	78 
��	&	��
�9�&,�
-�� 
��	&	��
")*��	
�� Script 
Programming CAD�� 
��	
�� Digitizer 
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 %	�&���	'!	,�%!)��-���!�,����%!;�(,+�+��<���	
��
��")*),�./*0���(�1�
 !	"�	�%�����	(,3

	*8,��+��&���	'
���	�9�
��1�
 !	"�	�, ��	�9�0�8 File paths, ��� default ")*��	"&8
1�
(,+ 
Feature 
 
 ��	!	,�%!)��-���!�,�1�
 General tab 
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 ����8�*)>��1�
 Options ��� General tab 4*!	*����!8�+-��	(,3
���&9�0	,� Experience 
 level, save options ")* VBA security 
 
 
 ��	(,3
���&9�0	,� Experience level 
 %	�&���	'�+��<���	"&8
1�
%���")* Toolbars  8-��	(,3
��� Experience level 
�	*0+��

��	(68(,3
 !	"�	�
�1,3�(��(,3
��� Default &9�0	,� Intermediate experience level %	�&���	'
�9�0�8 Experience level �8�8,
��3 

� Beginner 4*"&8
%����9�&,�
")* Toolbars %?:�*���%!;� Basic command 
� Intermediate 4*"&8
%����9�&,�
")* Toolbars ���%!;��9�&,�
&	��
+,('<��� 2-�6(6%!;�&�+�")*�9�&,�


&9�0	,���	"���1+,('< 
� Advanced 4*"&8
%����9�&,�
")* Toolbars �,3
0�8������-�� 

 
 ��	�9�0�8��	 Save �,( ��,(6 
��	0)��%)��-
��	@��-70�-1�
1����)%����%�68�AAB�8,�0	��%�	���
 Hang 0	�� Error �����	 Save 1����)%�>��+�
�-��%	���-C %	�&���	'�9�0�8
0� !	"�	��9���	 save 1����)%�>��+�%	���-C (����+
%+)� 8-�,( ��,(6 D2�

 !	"�	�4*�9�0�8	*-*��	 save  8-�,( ��,(6%!;�����")* !	"�	�4*%	6���,�	*-*%+)���	 save 
�,( ��,(64����	�9���	 save )��&<8 
 
 %����AE
�,� AutoSave �9�
�� !	"�	�4*&	��
�A)7���%!;�(,+�,8)��1�
 Drawing 123��� D2�
(,+
�A)74*%�>��+����%8�-+�,�(,+�A)71�
 Drawing D2�
%!;��A)7���&�<)���'���9�0�8
�&�+�1�
 AutoSave 
Drawing Extension ( 8-��� Default 4*%!;� .SV$) 
 
 ��	!F8��	�9�
��1�
 VBA CommonProject macros 

�"(�)*�	,3
���%	��9���	 start  !	"�	� CAD�� (,+ macro 4*�9���	 0)8(,+ Visual Basic 
Application (VBA) CommonProject 
0� 8-�,( ��,(6 '��%	����(��
��	���4*
��(,+ VBA 
�G�-0),
 
%	�&���	'!F8��	�9�
��1�
�,��8�0	���,�4*���&���	'
���8�'��%	��9�0�8(,+ Security 
�	*8,� Low 
 

+65���	%!)��-���!�,�
� General tab 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Options 
� :6�:7 config ")�+�8 Enter 

2. %)����!��� General tab 
3. 
�&�+�1�
 Experience level %)���	*8,��+���9���H1�
I��
�� Beginning, 

Intermediate 0	�� Advanced 
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4. 
�&�+�1�
 AutoSave %)����9�%�	���
0��-'��������
 Enable auto save every ")�+
�9�0�8	*-*%+)����(��
��	 Save �<�C ��+
%+)� 
'��%	�(��
��	%!)��-����&�<)1�
�A)7 AutoSave %	��>:6�:7���&�<)���%	�(��
��	)
���
���
 AutoSave drawing extension 

5. '��%	����(��
��	 0)8(,+ CommonProject macros (��%	��9���	 start  !	"�	� 
CAD�� %	��>%)����9�%�	���
0��-'��������
 Disable VBA CommonProject 
Macros ����-��
�&�+�1�
 VBA Security 

6. %����%&	>4")�+%	��>�8!<J� OK 
 

  
A. %)����9�%�	���
0��-'��%:���%!F8��	
�� AutoSave 
B. %)���	�!"����	�,��2� drawing 
C. %!F8 drawing 8�+-��	 recover 
D. D��� �9�%(���(��
 C 
�1/* Recover 
E. %)����9�%�	���
0��-'��%:���!F8��	
�� VBA CommonProject Macros (��%	��9���	 

start  !	"�	� 
F. :6�:7���&�<)1�
�A)7 AutoSave ���%	�(��
��	 
G. 	*�<��+
%+)����4*�9� AutoSave 0��+-%!;����� 
H. %)���	*8,��+���9���H1�
I��
��  Beginner, Intermediate, Advanced 
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 ��	%!)��-���!�,�
� Path/Files tab 
 %	�&���	'�9�0�8&'�����1�
�A)7���
��&9�0	,� Drawing, Font ")* Menu ����8�*)>�� 
Option 
� Path/Files tab %	�&���	'	*�<�!-,
�A)7��������&�<)���%0�����,�����-��
�&'�����(��
C 
"��(��%����
�!%	���-C ")�+%	�-,
&���	'%!)��-���� default 1�
�A)7���
��&9�0	,��9�0�8 Font ")* Error 
logging �8�8�+- 
 
 ��	�9�0�8 Path 1�
I��
�� 
 %	�&���	'	*�< Path ���%!;��8%	>��	�	�� 8-��	:6�:7)
�!
�&�+�1�
 Location 
��8�*)>�� 
Option D2�
%!;� path &9�0	,���	�9�0�8 Drawing, Font, Help, External reference, Menu ")* 
Hatch '������	�� path %	�&���	'�8�!���!<J� Brown %:���%)��� path ���%	�(��
��	 
 
%	�&���	'	*�< path "��(��%����
 &9�0	,��9�0�8 path 
�&�+�(��
C (,+�-��
%��� '��%	��� Drawing ���4*
��
����+��0�2�
 Drawing ���(��
��	%!F8 %	�&���	'�9�0�8 path %!;�"��(��%����
  8-
��%�	���
0��- 
Semicolon (“ ; ”) "-�	*0+��
"(�)* path   
 
 +65���	�9�0�8 Path 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Options 
� :6�:7 config ")�+�8 Enter 

2. %)����!��� General tab 
3. 
�&�+�1�
 Location %)������	�-��	���%	�(��
��	%!)��-� path ")�+:6�:7 path ���%	�(��
��	 

'������	�� path %	�&���	'�8�!���!<J� Brown %:���%)��� path ���%	�(��
��	 
4. %&	>4")�+�8!<J� OK 

 
 ��	%!)��-���� Default System files 
%	�&���	'%!)��-���� Default System Files ���!	*����!8�+-1�
��� Log file, Template, 
Alternate font ")* Font mapping file 
 
 +65���	%!)��-���� Default System files 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Options 
� :6�:7 config ")�+�8 Ente 

2. %)����!��� General tab 
3. ���&�+�8���)��
1�
�8�*)>�� 
�&�+�1�
 File �>�)6��!����A)7���%!;���� Default system file ���

%	�(��
��	%!)��-�")�+�>:6�:7�����A)7���(��
��	 
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'������	�������A)7%	�&���	'�8�!���!<J� Brown %:���%)����A)7���(��
��	 
4. :6�:7�����A)7���(��
��	 
5. %&	>4")�+�8!<J� OK 

 
 (������8��)��+��
�&�+�1�
��	�9�0�8 path ")* ��	�9�0�8��� Default System File ���
�8�*)>�� Option "&8

0�%0>�8���)��
 
 

 
A. !<J��)6�&9�0	,�%1���!%)��� �A)7���%!;� Default system file 
B. &�+�&9�0	,�%)���%!)��-���� 
C. !<J��)6�&9�0	,�%1���!%)��� A)%8�	7 
D. &�+�&9�0	,�%)��� %!)��-��8%	>��	�	�� 8-��	:6�:7 

 
 
 
 
 ��	%!)��-���!�,�
� Display tab 
 
��8�*)>�� Option ��� Display tab 4*%!;����&9�0	,��9�0�849��+�1�
 Command line to 
track, Screen color, ��	"&8
1�
 Prompt box ")* Automatic menu loading 
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A. 49��+��		�,8 )��&<8 �9�&,�
���%�>��+� 
B. "&8
 "�! tab 
C. "&8
 Scroll bar 
D. �)6�%:���!F8-%!F8��	"&8
1�
 Prompt box 
E. �)6�%:���!F8-%!F8��	�9�
��1�
 Automatic Menu Loading 
F. 
0�G�:���+��%?���- 0�<�(���! %����
����	0�<�"�� realtime  
G. :6�:749��+��		�,8���&���	'�		4<
� Prompt History windows 
H. %)���&�:63�0),
 1�
 drawing (��4�%����,3�) 
I. 
�� !<J�)��@	 123� )
 %:��� �+�0� �9�&,�
���
���!")�+ 

 
 ��	(,3
��� Command lines to track 
 %	�&���	'�9�0�849��+��		�,81�
(,+ Command line ���%�>��+�
�0��+-�+��49�
�1/*���%	�
��

�� D2�
��� Default  !	"�	�4*�9�0�8
0�%����,� 256 �		�,8 %	�&���	'8��9�&,�
")*1����)-���0),
���%	��8�

��
���!")�+�8�
� Prompt History windows ")*+65���	"&8
 Prompt History windows  8-
��	�8!<J� F2 ")*��	!F8�>�8!<J� F2 ����	,3
 
 
 ��	(,3
��� Graphics Screen color  
  8-��� default ")�+(,+ Background 1�
 Drawing 4*%!;�&�89� %	�&���	'�9���	%!)��-�&�1�

(,+ Background �8�(�����%	�(��
��	 
 



��������	
��
�� CAD��  

 ��	"&8
1�
 Prompt Box 
 %����%	�
���9�&,�
��
�9�&,�
4*
0�%	�%)�����!�,�����C (���!8�+- �>4*!	��L%���123���
0�%	�%)���0	�����
%	�-�+�� Prompt box D2�
�,�4*!	��L123�(��),�./*1�
"(�)*�9�&,�
 '�����(��
��	
0� !	"�	�"&8
 
Prompt box %	�&���	'���4*!F8��	"&8
1�
(,+ Prompt box �8� 8-%��%�	���
0��-'��������
 Display 
Prompt Boxes ��� 
 
 Automatic Menu Loading 
 
��	,3
"	����%	� start  !	"�	� CAD�� %������%!;� Default 4*'�� 0)8%1����")*(,+ 
Automatic Menu Loading ����-��
��8�*)>�� Option 4*%!;�%�	���
0��-'�� (,+ Automatic Menu 
Loading 4*�9���	 0)8%������I��(68�-���,� Drawing ���%	��9���	%!F8
0�%�
 8-�,( ��,(6 D2�
%	�&���	'�9�
��	!F8��	�9�
��1�
 Automatic Menu Loading �8� 
 

+65���	%!)��-���!�,�
� Display tab 
2. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Options 
� :6�:7 config ")�+�8 Ente 

3. %)����!��� Display tab 
4. &9�0	,� Command Lines To Track :6�:749��+��		�,8�9�&,�
���&���	'�		4<
� 

Prompt History windows 0	��!	,�!<J����%!;�)��@	123� (Up) - )
 (Down) 
5. &9�0	,� Graphics Screen Color �>�)6����!<J� Color ")�+4���,3��>%)���&����%	�(��
��	

")�+�8!<J� OK 
6. '��(��
��	!F8��	"&8
1�
 Prompt box 
0�%��%�	���
0��-'��������
 Display Prompt 

Boxes ��� 
7. '��(��
��	!F8��	 0)8%��� 8-�,( ��,(6 
0�%��%�	���
0��-'��������
 Automatic Menu 

Loading ��� 
8. %&	>4")�+�8!<J� OK 

 
   

 
 ��	%!)��-���!�,�
� Crosshairs tab 
 
��8�*)>�� Option ��� Crosshairs tab %	�&���	'�9�0�8��	"&8
1�
(,+ Crosshair %:���
��+-
0�%	���
%0>��+��"(�(��
1�
"�� X, Y ")* Z 
�&����"(�(��
�,� %	�&���	'�9�0�8&�1�
 
Crosshair 
�"(�)*"��%!)��-��!%!;�&�(��
C (�����%	�(��
��	")*%	�-,
&���	'%!)��-�1��81�
(,+ 
Crosshair ")*(,+ Pointer ���%!;���� Default 
 

+65���	%!)��-���!�,�
� Crosshairs tab 



��������	
��
�� CAD��  

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Options 
� :6�:7 config ")�+�8 Ente 

2. %)����!��� Crosshairs tab 
3. 
�&�+�1�
 Axis Color 
�"(�)*"�� %)����9�0�8&����(��
 8-�8�!���!<J� Color %&	>4

")�+�8!<J� OK 
4. '��%	�(��
��	
0�(,+ Pointer "&8
(��(,+ Crosshair �)6�������
 Pointer Default To 

Crosshairs 
0�%!;�%�	���
0��-'�� 
5. 
�&�+�1�
 Cursor Size :6�:7���%!�	7%D>�1�
1��8(,+ Crosshair ���"&8
�,�0���4�

0	��!	,�!<J����%!;�)��@	123� (Up) - )
 (Down) 
6. %&	>4")�+�8!<J� OK  

  
A. %)���&�1�
&,HH),�./7 "�� x,y,z 
B. �9�0�8(,+��3%!;� crosshairs 
C. 
�� grips 
���	"���1+,('< 
D. 	*-*�����I)(�� grips 
E. 1��81�
%��	7%D�	7 �68"�� %!�	7%D�(71�
4�G�: 
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 ��	%!)��-���!�,�
� Snapping tab 
 
��8�*)>�� Option ��� Snapping tab %	�&���	'�9�0�8��	"&8
1�
(,+ Fly-over 
snapping (,+ Fly-over snapping %!;�(,+�����+-
0�%	���
%0>���	�9�
��1�
(,+ Entity snap �8��-��
��
!	*&6�56G�:���123� 
 

+65���	%!)��-���!�,�
� Snapping tab 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Options 
� :6�:7 config ")�+�8 Ente 

2. %)����!��� Snapping tap 
3. %)���(,+%)������%	�(��
��	 
4. %&	>4")�+�8!<J� OK 

 

 
A Select to display an extra image on 
the cursor to 
show which entity snap is active. 
(Available even 
if fly-over snapping is turned off.) 
B Select to turn on fly-over snapping. 
C Select to turn on fly-over snap 
tooltips, which 
indicate the type of snap that was used 
to select 

the marked location. 
D Select to turn on the fly-over snap 
aperture box. 
Entities found within the aperture box 
are 
available for selection, making it easier 
to find 
and select entity snap points. 
E Type or scroll to the tolerance size 
for the flyover 
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snap aperture box. Higher numbers 
increase the distance from the cursor in 
which 
entities are found. 
F Type or scroll to the thickness of the 
fly-over 
snap marker. 
G Type or scroll to the size of the fly-
over snap 
marker. 

H Click to choose the color of the fly-
over snap 
marker. 
I Select to turn on the display of fly-
over snap 
markers in all views when you are 
using more 
than one viewport. 
J Select to turn on fly-over snap 
markers, which 
mark snap points on entities. 

 
 
 
��� Customize ������� 
 
 %	�&���	'�9���	 customize %������%	�
���-��")* save %�>��+�%!;��A)7
�),�./*1�
 CAD�� 
%��� ")�+%	�-,
&���	'�9��A)7%���%1����
�����+��4*%!;��A)71�
 CAD�� (*.icm) ")*�A)7%���1�
 
AutoCAD (*.mnu)  8-��	
���8�*)>�� Customize 
 

+65���	 Customize (,+%��� 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Menus tab 
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A. &�+�1�
%������"&8
�-����0���4� 
B. &�+�1�
��	�		4<�9�&,�
&9�0	,�"(�)*%��� 
C. &�+�1�
1���+�����4*"&8

� Status bar 
D. !<J��)6�&9�0	,��9��A)7%���%1����
�� 
E. !<J��)6�&9�0	,�&�
%�������!%!;��A)7 
F. !<J��)6�%:��� Reset �),��!%!;���� Default 
G. !<J��)6�&9�0	,��9�0�8��!�,�%:6��%(6�����8�*)>�� Menu Customization Options 
H. !<J��)6�&9�0	,��		4<�9�&,�
%1���!-,
%��� 
I. !<J��)6�&9�0	,� Rename (,+%��� 
J. !<J��)6�&9�0	,�%:6��0	��&	��
%������%!;� Menu Item, Menu Sub-Item, Spacer 0	�� 

Context Menu Item, Context Menu Sub-Item 
 

 ��	�9��+��%1��
4�,� Menu compatibility 
 �A)7���%!;����&�<) MNU %!;��A)7%������'��&	��
 8- !	"�	� AutoCAD ")*�A)7���&�<) 
MNS ���&	��
4�� !	"�	� AutoCAD Releases 13, 14 ")* 2000 D2�
 !	"�	� CAD�� &���	'
�����8��,3
&�
���&�<)	+��,3
%������&	��
8�+-�9�&,�
 AutoLISP 	�!���"&8
�-��8�����3"&8

0�%0>�'2
��	
��%���
1�
 AutoCAD 
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+65���	�9��A)7 MNU 1�
 !	"�	� AutoCAD %1����
�� 
1. :6�:7 menu ")�+�8 Enter 
2. 
����
 Files Of Type %)���%!;� AutoCAD Menu File (mnu) 
3. ����8�*)>�� Open Menu %)����!��� A)%8�	7 Support 1�
 !	"�	� AutoCAD 

")�+%)����A)7 Acad.mnu (0	�� Acad.mns &9�0	,� AutoCAD Releases 13, 14 
")* 2000) 

4. &9�0	,���	 0)8%���1�
 !	"�	� AutoCAD %1����
� !	"�	� CAD�� �>�)6����!<J� 
Open 
%	��>4*�8�%���1�
 !	"�	� CAD�� �����0���(�%0�����,� !	"�	� AutoCAD 

5. +65���	�8&��+���9�&,�

�%����,3�
���8�0	�����  8-��	%	�-��9�&,�
���!	��L�-��
�%�����
�� 
6. +65���	�),��!
��%���1�
 !	"�	� CAD�� %)����!���%��� Tools > Customize ")�+

�)6��!��� Menus tab ")�+�8!<J� Reset 
7.  +65���	�),��!
�� Toolbar 1�
 !	"�	� CAD�� %)����!���%��� Tools > 

Customize ")�+�)6��!��� Toolbars tab ")�+�8!<J� Reset 
 

 
%������%!;���� Default 1�
 !	"�	� CAD�� 

 

 
%�������9�%1����4�� !	"�	� AutoCAD 
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��	&	��
%���")*�9�&,�
123���
0�� 
%	�&���	'&	��
%���123���
0�� 8-��	 Insert %��� / (9�"0��
8�����1�
 Menu Tree ")�+
4���,3�%	�&���	'�		4<�9�&,�
)
�!
�%������&	��
123���
0�� ����,3
%	�-,
&���	'%:6�� Sub-menu 
")*"���1%���	+��,3
�9�&,�
������-��")�+ 8-��	 Add, Delete ")*4,8%	�-

0�� 
 

NOTE: ��������	
��

��
��	���
����������������	�����������������
�	�� ����������������������	���
�������!�"��#���������������� $���� (Experience level) "�� �&�	��������������	
����
��	���
������
����������	�����������������
 ����������������������	����������!�"��"��#���������������� $���� 
(Experience level) "�� �'(
�������������� $���� (Experience level)  ��"�������
����� Tools > 
Options 

 
+65���	&	��
%���123���
0�� 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Menus tab 
3. 
�&�+�1�
 Menu Tree %)���%������%	�(��
��	"�	�%���123�
0�� 
4. %)����!���!<J� Insert > Menu Item 
5. :6�:7����%������%	�(��
��	&	��
")�+�8 Enter  
6. �)6����!<J� Close 

 

���	%	�-�
��%������&	��
123���
0��%	�4*(��
�		4<�9�&,�
)
�!
�%������%	�&	��
123�%&�-���� 
 
+65���	�		4<�9�&,�
)
�!
�%��< 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Menus tab 
3. 
�&�+�1�
 Menu Tree %)���%������%	�(��
��	�		4<�9�&,�
 
4. %)����!���!<J� Insert > Menu Sub-Item 
5. :6�:7�����9�&,�
���%	�(��
��	")�+�8 Enter 
6. +65���	�		4<�9�&,�
 %	�&���	'�9�%)����9�(��
81,3�(��0�2�
8,
��3 

� %)����!-,
�����9�&,�
���%	�&	��
123�
�&�+�1�
 Menu Tree ")*4���,3��!%)����9�&,�
���
%	�(��
�		4<%1�����"&8
�-��
�&�+�1�
 Available Command ")�+4���,3��)6����
!<J� Add Command 
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� 
����
 Command :6�:7 Command string ")�+4���,3��)6����!<J� Add 
Command    

7. 
����
 Help String :6�:71���+�����%	�(��
��	
��"&8
�� Status bar 
�(�����%	�
%)����(,+ Cursor �!�,�����9�&,�
�,3�C 

8. '��(��
%:6���9�&,�
����C �>-����),��!�9�
�1,3�(����� 3-7 
9. %&	>4")�+�8!<J� Close 

 
������������: ��������&�!�$������	����
����	������!��� ��� ���	����#������ Access key )�
���*'�*+&�� 
Ampersand (&) �������&�����,��
����&������ ������ Access key �&����&������� -��� ���������� 
Access key -�&�������&�����,��
�"��.!�����/�
 �������

���� &���
����$�� #������*'�����	��� Quick Line ����
"� ����� Insert ����0 	�&�� &  ���
������&�����,� Q �����0-�����1�	���
��	�� &��
�&�����,���!� �����  �
�������� $����	����
!���	����#�����"��
����� Insert �������23�&�����,� Q �
� Keyboard 

 
+65���	 Rename (,+%��� 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Menus tab 
3. 
�&�+�1�
 Menu Tree %)���%������%	�(��
��	 Rename 
4. �)6����!<J� Rename 
5. :6�:7����%������(��%	�(��
��	")�+�8 Enter  
6. �)6����!<J� Close 
 

+65���	)�(,+%��� 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Menus tab 
3. 
�&�+�1�
 Menu Tree %)���%������%	�(��
��	)� 
4. �)6����!<J� Delete 
5. ����8�*)>�� Confirmation �)6����!<J� OK 
6.  �)6����!<J� Close 

 
NOTE: ����������
��
 Sub-Items �
�� �������!� &�� Sub-Item �
��
������ �-�#����"����
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��	(,3
 Experience level &9�0	,�%���")*�9�&,�
 
%	�&���	'(,3
 Experience level &9�0	,�%���")*�9�&,�
���%	�&	��
123���")*&���	'%!)��-� 
Experience level 
�%���")*�9�&,�
������-���8� 
 
+65���	(,3
 Experience level &9�0	,�%���")*�9�&,�
 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Menus tab 
3. 
�&�+�1�
 Menu Tree %)���%���0	���9�&,�
���%	�(��
��	%!)��-� Experience level 
4. �)6����!<J� Option 
5. ����8�*)>�� Menu Customization Options 
�&�+�1�
 Experience level �>

%)���	*8,���	
��
�� (Experience level) ���%	�(��
��	�9�0�8
0�%���0	���9�&,�
�,3�%!;� 
6. �)6����!<J� OK 
7. �)6����!<J� Close 

 
NOTE: ����� $� Experience level  ��&���������&�������������
�	2� �*������	���-��	�� ������4*�� 
����� Experience level �
����"��������"�� #������������ Experience level ���� Intermediate �*

�
�
�����

� ���	�����!��0-�����1�4*�� ������ Experience level �
����� Intermediate �
�����

�������!� 
��� Save ������0�"������"5�+ 
 

 !	"�	� CAD�� 4*�9���	 Save %�>�%������%	��9���	%!)��-�"!)
 8-�,( ��,(6 D2�
%	�&���	'
&	��
")*%�>�%���1�
%	����%	�&	��
�+��8�  !	"�	�4*�9���	 Save %�>�%���
�	�!"��1�
�A)7
���&�<) *.icm 
 
+65���	 Save %���%�>��+�%!;��A)7 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Menus tab 
3. �)6����!<J� Export 
4. ����8�*)>�� Select Menu File �>%)���&'�����%�>�")*(,3
�����A)7���%	�(��
��	 
5. �)6����!<J� Save 
6. �)6����!<J� Close 
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NOTE: ��� Save ��0������
����	������!���!�-�"�����"�#��&�� Toolbar �
����	������!��������"� 
 
 

��	 0)8�A)71�
%���%1����
�� 
%	�&���	' 0)8%���4���A)7%������%	��8�&	��
�+�%1����"��%������%	�
���-��  !	"�	�&���	'�9�%1��
�A)7%����8��,3
�A)7%���1�
 !	"�	� AutoCAD (*.mnu, *.mns) ")* !	"�	� CAD�� 
(*.icm) 

 
+65���	 0)8�A)71�
%���%1����
�� 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Menus tab 
3. �)6����!<J� Import 
4. ����8�*)>�� Select Menu File �>%)����A)7���%!;��A)7���&�<) *.mnu, *.mns ")* 

*.icm 
5. %)����A)7%������(��
��	 
6. �)6����!<J� Open 
7. �)6����!<J� Close 

 
NOTE: ���)��������
����	���������� $����-�����������4*��&������������!�-�"�����"�#��&�� Toolbar  
 

��	&	��
 Shortcut %���123���
��%�
 
 
� !	"�	� CAD�� %	�&���	'&	��
 Shortcut %���&9�0	,��9�&,�
���%	�
�����-C 123���

�� %	�&���	'%	�-�
�� Shortcut %��� 8-��	�8!<J� Shift ")*�8!<J����8���1+�1�
%��&7 (Right 
click) 
���	&	��
 Shortcut %���%	�&���	'
�� !	"�	�49�:+� ASCII text editor %��� 
NotePad ")* WordPad 8,
(,+�-��
���"&8
�-��8���)��
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+65���	&	��
 Shortcut %��� 
8,
(,+�-��
(���!��34*"&8
	�-)*%��-8
���	&	��
 Shortcut %�������		4<�9�&,�
 Line, Hatch, 
Dtext, Circle ")* Erase  

1. %!F8 !	"�	�49�:+� ASIIC editor %��� NotePad 0	�� WordPad 
2. :6�:71���+�����"&8
�-��8���)��
 

 

 
3. �9���	 Save %�>�%!;��A)7���� Example.mnu 
� A)%8�	71�
 !	"�	� CAD�� 

 
+65���	�9� Shortcut %������&	��
�+�%1����
�� 

1. %	�-� !	"�	� CAD�� 123��� 
2. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

3. %)����!��� Menus tab 
4. �)6����!<J� Import 
5. ����8�*)>�� Select Menu File �>%)����A)7%������%	�&	��
�+� (Example.mnu) 
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6. %)����9�%�	���
0��-'��������
 Append To Current Menu ")�+�)6�!<J� Open 
'��%	�����9�%�	���
0��-'��������
 Append To Current Menu (,+%������%	�
���-��4*'��
)��!")* Shortcut %���4*!	��L123���"����� 

7. �)6����!<J� Close 
8. %)����!-,
+,('<����-��
� Drawing ")�+�8!<J� Shift ���
�+�")�+�8!<J�%��&78���1+� 
9. %)����9�&,�

� Shortcut %������%	�(��
��	
�� 

 
+65���	-����),��!
�� Shortcut %���%86� 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. �)6����!<J� Reset 
 
 
��� customize ��� Toolbar 
 
  !	"�	� CAD�� �8�4,8%(	�-� Toolbar &9�0	,�%	�-�
���9�&,�
�8�
��-")*&*8+����123� %	�
&���	' customize (,+ Toolbar  8-��	%:6��0	��)�0	��4,8%	�-

0�� ����,3
%	�-,
&���	'&	��
%:6��%(6� (,+ 
Toolbar �,�4*'��&	��

0�%!;�&�+�0�2�
1�
 !	"�	� %	�-,
&���	'���4*&�
��� (Export) ����!%!;��A)7 
")*%	�&���	'�9�%1�� Toolbar 4�� !	"�	� AutoCAD %	�&���	'�9���	 customize (,+ Toolbar �8�
����8�*)>�� Customize ")*%)����!-,
 Toolbars tab 
 

+65���	 customize (,+ Toolbar 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. �)6���� Toolbars tab 
3. 
���	 customize (,+ Toolbar %	�&���	'�9�(��1,3�(�����"&8

0�%0>��-��8���)��
��3 

 



��������	
��
�� CAD��  

 
A. &�+�1�
�<8�9�&,�
���"&8
	�-��	1�
 Toolbar 
B. ���
&9�0	,�:6�:71���+�����%	�4*�,�"&8

0�%	��	��%����(�����%	�%)����%��&7�!�,���� 

Toolbar  
C. ���
&9�0	,�:6�:71���+�����"&8

0�%	��	����� Status bar (�����%	�%)����%��&7�!�,���� 

Toolbar  
D. ���
&9�0	,�:6�:7�9�&,�
&9�0	,� Toolbar  
E. &�+�&9�0	,�"&8
 Toolbar 1�
"(�)*	�-��	 

 
 ��	&	��
 Toolbar 123�
0�� 
 %	�&���	'&	��
 Toolbar 123���
��
0�� 8-��	)��(,+ Toolbar �9�&,�
4���8�*)>�� Customize 
�!+�
)
��:�3����1�
 Toolbar ����C 
� !	"�	� CAD�� %	�&���	'&	��
 Toolbar 123���
0��")*
4���,3�%	��>�9�0�8����1�
 Toolbar ���%	�&	��
123� 0),
4���,3�%	�42
%:6��(,+ Tool �9�&,�
)
�!
�:�3����1�
 
Toolbar ���&	��
123��� %	�-,
&���	'%:6��, )�0	��"���1(,+ Tool �9�&,�
����		4<�-��
� Toolbar �8� %����%	�
&	��
 Toolbar  8-
�� Tool �9�&,�
4��&�+�1�
 Button 
��8�*)>�� Customize  8-���1�
 Tool
%�	>8�+��	��, Help String ")* Command (����� Default 1�
 Tool �9�&,�
�,3�4*�		4<)
�!
� Tool 
�9�&,�
 8-�,( ��,(6 ")*%	�-,
&���	'"���1��� Default %0)����31�
"(�)* Tool �9�&,�
�,3� 8-�,( ��,(6 ")*%	�
-,
&���	'"���1��� Default 1�
 Tool �9�&,�
1�
"(�)* Tool �9�&,�
�8� 
 

 +65���	&	��
 Toolbar 123�
0�� 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
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� :6�:7 customize ")�+�8 Enter 
2. �)6���� Toolbars tab 
3. 
�	�-��	1�
 Categories %)���	�-��	���(��
��	")*"(�)*	�-��	�,�4*"&8
(,+ Tool 
�9�&,�
���'���		4<
�	�-��	�,3�C 

4. �)6���� Tool �9�&,�
")*)�����4���8�*)>�� Customize �!+�
-,
:�3����8������1�

�8�*)>�� 

5. "���1��� Tool%�	>8�+��	��, Help String ")* Command (�����%	�(��
��	 
6. %&	>4")�+�)6�!<J� Close 

 
+65���	%:6�� Tool �9�&,�
)
�!-,
 Toolbar 
%	�(��
"��
4+��(,+ Toolbar ���%	�(��
��	%:6��(,+ Tool �9�&,�
�,3�"&8
�-���� Screen  

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. �)6���� Toolbars tab 
3. 
�	�-��	1�
 Categories %)���	�-��	���%	�(��
��	%:������4*"&8
 Tool �9�&,�
���%	�(��
��	 
4. �)6���� Tool �9�&,�
���(��
��	")*)���!+�
-,
 Toolbar ���(��
��	 
5. "���1��� Tool%�	>8�+��	��, Help String ")* Command (�����%	�(��
��	 
6. '��%	�(��
��	%:6�� Tool �9�&,�
�!-,
 Toolbar ��� �>-����),��!-,
1,3�(����� 3-5 
7. %&	>4")�+�8 Close 

 
+65���	)� Tool �9�&,�
���4�� Toolbar 
%	�(��
"��
4+��(,+ Toolbar ���%	�(��
��	)�(,+ Tool �9�&,�
�,3�"&8

� Screen 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. �)6���� Toolbars tab 
3. �)6���� Tool �9�&,�
����-��
� Toolbar ���%	�(��
��	)�")�+)���),�������8�*)>�� Customize 
4. %&	>4")�+�8 Close 

 
+65���	%!)��-�(9�"0��
+�
1�
(,+ Tool �9�&,�

� Toolbar 
%	�(��
"��
4+��(,+ Toolbar ���%	�(��
��	"���1�,3�"&8
�-���� Screen 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 
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2.  �)6���� Toolbars tab 
3. ��� Toolbar %	�(��
��	%!)��-�(9�"0��
+�
1�
(,+ Tool �9�&,�
 �>�)6��!-,
 Tool �9�&,�
")�+)��

�!+�
"�	�-,
(9�"0��
�������(��
��	 
1���+		*+,

���	)��(,+ Tool �9�&,�
�!+�
�,3� 
�1/*+�
%	�(��
���+�
(,+ Tool �9�&,�

0�%)-
������:�3����1�
 Toolbar %:	�*�,�4*%!;���	)�(,+ Tool �9�&,�
�,3� 

4. %&	>4")�+�8!<J� Close 
 

��	%!)��-����� Toolbar 
 %����%	�&	��
 Toolbar 123���
0��  !	"�	��9�0�8����1�
 Toolbar 
0�%	�%�
 8-�,( ��,(6 %��� 
ToolBar1, ToolBar2 ")*(���!%	���- C ����1�
 Toolbar 4*"&8
�-���� Titlebar 1�
(,+ 
Toolbar ")*%	�&���	'%!)��-�����1�
 Toolbar �8�(�����%	�(��
��	 
 
����8�*)>�� Select Toolbars %	�&���	'%!)��-�����(,+ Toolbar ")*�9���	!F8-%!F8 ��	"&8
1�
(,+ 
Toolbar ")*�9�0�8
0�"&8
%!;�"�� Large icon 0	�� Small icon 	+��,3
&���	'�9�0�8
0�(,+ 
Toolbar "&8
%!;�&�0	��1�+-89� ")*%	�&���	'�9�0�8��	"&8
1�
(,+ Tool%�	>8�+��	�� �8�8�+- 

 
+65���	%!)��-����� Toolbar 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� View > Toolbars 
� :6�:7 tbconfig ")�+�8 Enter 

2. 
�	�-��	1�
 Toolbar %)��� Toolbar ���%	�(��
��	%!)��-����� 
3. 
����
1�
 Toolbar Name :6�:7���� Toolbar ���%	�(��
��	 
4. %&	>4")�+�8!<J� OK 
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A. &�+�1�
	�-��	1�
 Toolbar �,3
0�8 
B. %)��� Toolbar ���%	�(��
��	%!)��-����� 
C. :6�:7 Toolbar ���%	�(��
��	)
�!
0�� 
D. %)����9�%�	���
0��-'��%����%	�(��
��	
0� Toolbar "&8
%!;�1��8
0H� 
E. %)����9�%�	���
0��-'��%����%	�(��
��	
0� Toolbar "&8
%!;�&� 
F. %)����9�%�	���
0��-'��%����%	�(��
��	
0� Toolbar "&8
 Tool%�	>8�+��	�� 
G. �)6�%����%	�(��
��	%	�-��8�*)>�� Customize 

 
 
 ��	&	��
 Toolbar "�� Flyout 
 ��	&	��
 Toolbar "�� Flyout %!;���	&	��
 Toolbar ����9�0�8
0� Tool �9�&,�
%	�-
�,�)
��
(��"�+8���)��
 &9�0	,� Toolbar �������	&	��
"�� Flyout ���(,+ Tool �9�&,�
���%!;�"�� Flyout 4*"&8

	�!&��%0)��-�%)>� C �-��1+����8���)��
1�
 Tool �9�&,�
�,3� %����%	��)6���� Tool �9�&,�
 (,+ Tool �9�&,�
���� C ���
D����-�� �>4*!	��L123�%!;�"'+%	�-
)
��8���)��
 %	�&���	'%)���
���9�&,�
 8-�!���(,+ Tool �9�&,�
�,3� C ")* 
Tool �9�&,�
�,3��>4*!	��L123���"�� Tool �9�&,�
%86����!	��L�-�� %	�&���	'%:6��%(6� Tool �9�&,�
"�� 
Flyout �8�(�����%	�(��
��	 
 

+65���	&	��
 Toolbar "�� Flyout 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2.  �)6���� Toolbars tab 
3. %)����9�%�	���
0��-'��������
 Insert As Flyout 
4. 
�	�-��	1�
 Categories %)��� Toolbar ���%	�(��
��	 
5. 
�&�+�1�
 Button %)��� Tool �9�&,�
���%	�(��
��	")�+)���!+�
-,
 Tool �9�&,�
����-��
� 

Toolbar ���%	�(��
��	 
6. "���1 Tool%�	>8�+��	��s, Help String ")* Command (�����%	�(��
��	 
7. '��%	�(��
��	&	��
%:6�� �>-����),��!-,
1,3�(����� 4-6 
8. %&	>4")�+�8!<J� Close 

 
 
 ��	(,3
	*8,���	
��
��&9�0	,� Tool �9�&,�
 (Experience level) 
 %	�&���	'(,3
	*8,���	
��
��&9�0	,� Tool �9�&,�
����-��
� Toolbar ���%	�&	��
123���
0��")*%	�-,

&���	'%!)��-�	*8,���	
��
��1�
 Tool �9�&,�
����-��
� Toolbar ������-��")�+�8� 
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+65���	(,3
	*8,���	
��
��&9�0	,� Tool �9�&,�
 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. �)6���� Toolbars tab 
3. �)6�%)����!-,
 Tool �9�&,�
����-��
� Toolbar ���%	�(��
��	(,3
	*8,���	
��
�� 
4. ����8�*)>�� Customize %)����!���!<J� Options 
5. 
�&�+�1�
 User level %)���	*8,���	
��
��(�����%	�(��
��	
0��,�(,+ Tool �9�&,�
 
6. �)6����!<J� OK 
7. %&	>4")�+�)6����!<J� Close 

 
NOTE:  ����� $� Experience level  ��&���������&�������������
�	2� �*��� Tool ���	���-��	�� � 
Toolbar �4*������� Experience level �
����"��������"�� #������������ Experience level ���� 
Intermediate �*

��
�����

� Tool ���	���*�!��0-�����1�4*����������� Experience level �
����� 
Intermediate �
�����

�������!� 
 

��	"���1 Tool �9�&,�
 
 !	"�	� CAD�� �8�4,8%(	�-�(,+ Tool �9�&,�
���%!;��9�&,�
���
��
��
� !	"�	��+�%�����,3
0�8 D2�
 
Tool �9�&,�
%0)����34*"&8
�-��
��8�*)>�� Customize 
� Toolbars tab %	�&���	'���4*"���1 
Tool �9�&,�
���&	��
��123�
0��")*4,8+�
�-��
��)<��1�
 Toolbar 1�
%	�%�
�8�8�+-  
 
Tool �9�&,�
���%	�&	��
123�%�
�,3�%	�4*&	��
4���A)7���%!;� Bitmap (*.bmp)  8-&���	'&	��
4��
 !	"�	� Paint 0	�� Illustration %:	�*+��%	�&���	'�9�0�8(,+ Tool �9�&,�
�8��,3
"��%)>�, 
0H� 
"&8
%!;�&�0	��1�+-89� D2�
(��
���+��"(�(��
�,� 4 "�� D2�

���	�9�0�81��81�
(,+ Tool �9�&,�
 
%	�&���	'�9�0�8�8�8,
��3 
 

� 1��8%)>� 16 x 15 Pixels 
� 1��8
0H�  24 x 22 Pixels 

 
NOTE: #������������������&�����/�* (Bitmap) ����"��������������
������� �� )������-�������

������
��&�����/�* (Bitmap) ��!� ��"��&�������
������� .���-���� ��/�*�
�"����--�6'��*
!
�"�-�����-�'� 
 

+65���	"���1 Tool �9�&,�
 
%	�(��
"���
4+�� Toolbar ���%	�(��
��	"���1�,3�!	��L�-���� screen 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
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� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2.  �)6���� Toolbars tab 
3. �)6�%)����!-,
 Tool �9�&,�
����-��
� Toolbar ���%	�(��
��	"���1 
4. ����8�*)>�� Customize %)����!���!<J� Options 
5. ����8�*)>�� Toolbar Customize Option 
�&�+�1�
 Button Bitmap �)6��!���

!<J�������
 Small, Color Button 
6. ����8�*)>�� Select Bitmap %)����A)7���%	�&	��
%(	�-��+�0	���A)7���%	�(��
��	 
7. �)6����!<J� Open 
8. -����),����9����1,3�(����� 5-7 &9�0	,����
 Large, Color Button ���
 Small, 

Black and White ")* ���
 Large, Black and White Button 
9. �)6����!<J� OK 
10. %&	>4")�+�)6����!<J� Close 

 

 
�8�*)>�� Toolbar Customize Option 

 
��	�9�%1�� Toolbar 
 !	"�	� CAD�� &���	'�9�%1�� Toolbar ���&	��
4�� !	"�	� AutoCAD ���%!;��A)7  
.MNU, .MNS %	�&���	'�9�%1�� Toolbar 4�� !	"�	� AutoCAD �8�4���8�*)>�� 
Customize ��� Toolbars tab 
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+65���	�9�%1�� Toolbar 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2.  �)6���� Toolbars tab 
3. �)6����!<J� Import 
4. %)����A)7 .MNU 0	�� .MNS ���%	�(��
��	 
5. �)6����!<J� Open 
6. %&	>4")�+�)6����!<J� Close 

 
 
 ��	&	��
 Toolbar 4���A)7 
 %	�&���	'&	��
 Toolbar 4���A)7")�+%	�-,
&���	'�9��!
0�������
���8�8�+- D2�
��	&	��
�A)71�
 
Toolbar �,3�%	�&���	'
�� !	"�	�49�:+� ASCII text editor �9���	&	��
 8,
(,+�-��
���"&8
�-��8���)��
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+65���	&	��
 Toolbar 4���A)7 
1. %!F8 !	"�	� ASCII text editor %��� !	"�	� NotrPad ")* WordPad %!;�(�� 
2. :6�:71���+��(�����"&8

0�%0>��-��8���)��
 
 

 
 
3. ")�+ save %�>�%!;��A)7���&�<) .MNU 

 
+65���	�,8)����� Toolbar ������-��")�+��
�� 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 



��������	
��
�� CAD��  

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2.  �)6���� Toolbars tab 
3. %)����!-,
 Tool �9�&,�
���%	�(��
��	�,8)����� 
4. �,8)�����4�����
 Tool%�	>8�+��	��, ���
 Help String ")*���
 Command �!+�
-,


A�	7�1�
��	%1�-��A)71�
 Toolbar 
5. ")�+ save %�>�%!;��A)7���&�<) .MNU 

 
+65���	�9��A)7 Toolbar ���&	��
�+��!
�����%�	���
���� 

1. �,8)���A)7 .MNU ���%	�&	��
�+�	+��,3
�A)7 Bitmap �!�+�-,
 A)%8�	71�
 !	"�	� 
CAD�� 

2. %!F8 !	"�	� CAD�� 
3. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

4.  �)6���� Toolbars tab 
5. �)6����!<J� Import 
6. %)����A)7 .MNU ����8�%(	�-��+� 
7. %)����9�%�	���
0��-'��������
 Append To Current Menu 

'��%	�����9�%�	���
0��-'��������
 Append To Current Menu (,+ Toolbar ���%	�
���-��
4*'��)��!")*(,+ Toolbar ���%	��9�%1����4*!	��Q123���"����� 

8. �)6����!<J� Close 
 
+65���	-����),��!
�� Toolbar ���%!;���� Default 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. �)6����!<J� Reset 
 
 
��� customize ������ Keyboard 
 
  !	"�	� CAD�� �8�4,80�%�	���
���&9�0	,�%	�-�
���9�&,�

�),�./*���%!;� Shortcut key ")*%	�
&���	'"���10	��%:6��%(6�(,+ Shortcut key �8� 8-"���1����8�*)>�� Customize 
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+65���	 customize (,+"!B��8 Keyboard 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Keyboard tab 
3. ��	�9�0�8 Shortcut key 123���
0���>:6�:7 Shortcut key ���%	�(��
��	)

����
 Press 

New Shortcut key 
4. ��	�9�0�8�9�&,�
&9�0	,� Shortcut key �>:6�:7�9�&,�
)

����
 Command 
5. ��	�9�%1���A)7&9�0	,� Shortcut key �>�)6��!���!<J� Import 
6. ��	%�>���� Shortcut key �!%!;��A)7 �>�8�!���!<J� Export 
7. ��	�9�0�8�9�&,�
%1���!
� Shortcut key �>%)����9�&,�
���(��
��	������
 Available 

Command ")*%)��� Shortcut key ���(��
��	")�+�8!<J� Add Command 
8. ��	%:6�� Shortcut key 123�
0�� �>�8���!<J� New 

 

  
A. &�+�&9�0	,� �+7 Shortcut key ������-��")�+ 
B. ���
&9�0	,��9�0�8 Shortcut key 
���	%:6�� Shortcut key 
C. ���
&9�0	,��9�0�8�9�&,�
&9�0	,� Shortcut key 

 
��	&	��
 Keyboard shortcut 
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%	�&���	'
�� Macro �9�0�8!<J��8�� Keyboard &9�0	,���	&	��
 Keyboard shortcut (,+ 
Macro 4*!	*����!8�+-0�2�
�9�&,�
0	������+���>�8�(�����"&8
�� Status bar 8,
��3 

� �9�&,�
%��� QSAVE 
� �9�&,�
	�+��,���!�,�%��� ARC;\A;\\ 
� ����+��0�2�
�9�&,�
%��� ^C^C^CZOOM;E;QSAVE;QPRINT 

��	
��(,+ Keyboard shortcut 4*
��!	* -��7�8�����+����	
���9�&,�
-�� (Alias) D2�
��	��	
��
�9�&,�
-��4*
���9�-��1�
�9�&,�
"(� Keyboard shortcut 4*�		4<�8�����+��0�2�
 Macro D2�
��	%	�-� 
Macro �����
��%	�&���	'%	�-��8� 8-��	�8!<J���� Keyboard D2�
%	����(��
�8!<J� Enter ���
%0�����,���	
���9�&,�
-��(,+ Shortcut key 4*!	*����!8�+-!<J�8,
��3 

� !<J� Ctrl, Alt ")*!<J� Shift D2�
��	
��!<J� Shift %	�4*(��

��	�+��,�!<J� Ctrl, Alt ")* 
Furction key (��
C  

� (,+0�,
&�� A-Z ")*(,+%)1 1-0 
� !<J� Cursor key %���!<J�)��@	 Up, Down, Left, Right ")*!<J� Page Up, Page 

Down, Home, End, Insert ")* Delete 
� !<J� F1-F12 

 
+65���	&	��
 Keyboard shortcut 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Keyboard tab 
3. �)6�!<J� New 
4. ������
 Press New Shortcut key �8!<J� Alt+A  !	"�	�4*%:6�� Alt+A %1���!
�

	�-��	
�&�+�1�
 Defined key  
5. 
�&�+�1�
 Available Command %)����!����9�&,�
 Are Center-Start-Angle 
6. �)6��!���!<J� Add Command  !	"�	��		4<�9�&,�
%1���!
����
 Command ")*
�

!<J� Shortcut key  
7. �)6�!<J� Close %:���%�>���� 
8. ��	%	�-��9�&,�
�����
���>�8!<J� Alt+A 

 
+65���	%!)��-��9�&,�

� Keyboard shortcut 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 
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2. %)����!��� Keyboard tab 
3. 
�&�+�1�
 Defined keys %)��� Shortcut key ���%	�(��
��	%!)��-� 
4. 
����
 Command �9���	%!)��-��9�&,�
(�����%	�(��
��	&���	'�9��8�8,
(���!��3 

� �)6��!���!<J� Add Command ���%	�(��
��	%!)��-��9�&,�
 
� "���1�9�&,�
���"&8
�-��
����
 Command 

5. �)6�!<J� Close 
 

+65���	)� Keyboard shortcut 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Keyboard tab 
3. 
�&�+�1�
 Defined key %)����!��� Shortcut key ���%	�(��
��	)� 
4. �)6�!<J� Delete 
5. �)6�!<J� Close 

 
 ��	 save %�>���� Keyboard shortcut �+�%!;��A)7 
  !	"�	� CAD�� 4*�9���	%�>���� Keyboard shortcut ���%	�&	��
123�0	��"���1
0�%	� 8-
 �,( ��,(6 ")* !	"�	�%�>���� Keyboard shortcut �+�%!;��A)7���&�<) *.ICK 
 

+65���	 save %�>� Keyboard shortcut �+�%!;��A)7 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Keyboard tab 
3. �)6�!<J� Export 
4. �9�0�8&'��������%	�(��
��	%�>��A)7 Keyboard shortcut 
5. �)6�!<J� Save 
6. �)6�!<J� Close 

 
 ��	�9�%1���A)7 Keyboard shortcut 
 %	�&���	'%!)��-�(,+ Keyboard shortcut 
0�� 8-��	�9�%1���A)71�
 Keyboard shortcut 
 

+65���	�9�%1���A)7 Keyboard shortcut 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
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� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Keyboard tab 
3. �)6�!<J� Import 
4. %)����A)7���(��
��	 
5. �)6�!<J� Open 
6. �)6�!<J� Close 

 
 
���������������� � (Alias) 
 
  !	"�	� CAD�� �8�4,8%(	�-��9�&,�
-�� (Alias) &9�0	,��9�&,�
(��
C %	�&���	'
���9�&,�
-���9���	
%	�-�
���9�&,�
 8-��	:6�:7(,+�,�.	-�� 1 0	�� 2 (,+�,�.	 
 
  !	"�	�-,
�		4<�9�&,�
-�����&9�0	,�%	�-�
���9�&,�
���(	
�,��,� !	"�	� AutoCAD ")*%	�-,

&���	'
�� �9�&,�
-�� (Alias) ")* Keyboard shortcut 4�� !	"�	� AutoCAD  !	"�	� CAD�� 
�8�%:6���+��&���	'1�
�9�&,�
�9�&,�
-��
0�����+�� !	"�	� AutoCAD (,+�-��
%���  !	"�	� CAD�� �8�
%:6����!�,�&9�0	,��9�&,�
 Rectangle ���%	�&���	'%1�-�+,('<	�!&��%0)��-�")*%	�-,
&���	'�9���	 rotate 
+,('<�,3� / �<�(��
C �8� 
%	�&���	'"���1�9�&,�
-��")*%	�&���	'%:6��123���
0��  8-"���1�8�����8�*)>�� Customize 
 

+65���	%	�-��8�*)>�� Customize 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

 2.%)����!��� Aliases tab 
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A. &�+�1�
��	"&8
�9�&,�
-�� (Alias) ������-��")�+ 
B. ���
"&8
�9�&,�
-�� (Alias) ���%	�%)��� 
C. &�+�1�
�9�&,�
���4*
��&9�0	,��9�0�8�9�&,�
-�� (Alias) 

 
 ��	&	��
, ��	�9�0�8")*��	)��9�&,�
-�� (Alias) 
 ��	&	��
�9�&,�
-��123���
0��%	��>�9���	�9�0�8�9�&,�
-��123��� ")�+4���,3���	�9�0�8�9�&,�
)
�!-,

�9�&,�
-�����&	��
123��� 
 

+65���	&	��
�9�&,�
-��123���
0�� 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Aliases tab 
3. �)6����!<J� New 
4. ������
 Alias :6�:7�,�.	-�����%	�(��
��	�9�0�8 
5. 
�&�+�1�
 Available Command %)����9�&,�
���%	�(��
��	�9�0�8)
�!-,
�9�&,�
-�� 

(Alias) ���%	��9�0�8123���
0�� 
6. �)6����!<J� Assign 
7. �)6����!<J� Close 
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+65���	�9�0�8�9�&,�
-��������-��")�+
0�� 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Aliases tab 
3. 
�&�+�1�
  Aliases list %)����9�&,�
-�����%	�(��
��	"���1 
4. 
�&�+�1�
 Available Command %)����9�&,�
���%	�(��
��	�9�0�8)
�!-,
�9�&,�
-�� 
5. �)6����!<J� Assign 
6. �)6����!<J� Close 

 
+65���	)��9�&,�
-��������-��")�+  

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Aliases tab 
3. 
�&�+�1�
 Aliases %)����9�&,�
-�����%	�(��
��	)� 
4. �)6����!<J� Delete 
5. �)6����!<J� Close 

 
 ��	 save %�>�����9�&,�
-�� (Alias) �+�%!;��A)7 
  !	"�	� CAD�� 4*�9���	%�>�����9�&,�
-�� (Alias) ���%	�(��
��	"���1 8-�,( ��,(6")�+%	�-,

&���	' save %�>��9�&,�
-���+�%!;��A)7�8�8�+- 
���	%�>��9�&,�
-��%!;��A)7�,3�%	�&���	'%�>��+�%!;��A)7
���&�<)  *.ICA ")�+%	�&���	' save �!%!;��A)7&9�0	,� !	"�	� AutoCAD �8�8�+- D2�
%	�4*%�>��+�
%!;��A)7  *.PGP 
 

+65���	 save %�>�����9�&,�
-���+�%!;��A)7 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Aliases tab 
3. �)6����!<J� Export 
4. ������
 Save As Type %)����A)7���&�<)���%	�(��
��	 (*.ICA 0	�� *.PGP) 
5. 	*�<&'��������%	�(��
��	%�>��A)7 
6. �)6����!<J� Save 
7. �)6����!<J� Close 
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+65���	�9�%1���A)7 �9�&,�
-�� (Alias) 

 %	�&���	'�9��9�&,�
-��
0��%1����
��"��(,+�9�&,�
-��%��� D2�
 !	"�	�&���	'�9�%1���9�&,�
-���8��,3
4��
 !	"�	� AutoCAD (*.PGP) ")* !	"�	� CAD�� (*.ICA) 
 

+65���	�9�%1���A)7�9�&,�
-�� 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Customize 
� :6�:7 customize ")�+�8 Enter 

2. %)����!��� Aliases tab 
3. �)6����!<J� Import 
4. 
����
 Files Of Type %)����A)7���&�<)���%	�(��
��	�9�%1�� 
5. �)6����!<J� Open 
6. �)6����!<J� Close 

 
��� Create �	
 Replay scripts 
 
  !	"�	� CAD�� &���	'���4*%�>��,��2�1����)���%	�!B��)
�� Keyboard ")*(9�"0��
�<�C 
(9�"0��
���%	�%)���)
�� Drawing ")*%	�&���	'%�>�1����)%0)����3%�>�%!;� script �A)7 (*.SCR) ")*
&���	'-����),���	�9�
��
0�� 8-��	 Replay (,+ script %	�&���	' script �A)7-����),��9�&,�
, "&8

G�: Snapshot 0	�� Batch plotting 	+��,3
%	�&���	' Load ")* Run (,+ script �A)7�����4��
 !	"�	� AutoCAD �8� 
 
 !	"�	� CAD�� &���	'	�
	,��A)7���%!;�1�
 AutoCAD customization ���!	*����A)7 Menu 
�A)7 script ")* LISP 	+��,3
 !	"�	� CAD�� -,
�� Linetype, Hatch pattern, Units 
translating ")* Command alias ���(	
�,��,� !	"�	� AutoCAD 	+��,3
&���	'�9��A)71�

AE
�,���7%0)����3���%	��8��9�0�8�+���
��D2�
�9�
0�%	�&���	'���4*
��
��(,+ !	"�	�
�	�!"�����%	�(��
��	�8� 
 
(,+�A)7 script 4*%!;�),�./*1�
 text file (,+ script 4*�		4<�!����		�,81�
(,+0�,
&��0	��1����)����C 
�-��
%��� %����%	�:6�:7�9�&,�
")�+�8 Enter 1����)%0)���,3��>4*'���,��2�%�>��+�
� script file 0	��%�����)6�%��&7
�!���(9�"0��

8(9�"0��
0�2�

� Drawing (,+ coordinate �>4*'���,��2��+�
� script file D2�
%	�&���	'
&	��
 script file 
� !	"�	�49�:+� Text editor %��� Microsoft NotePad 0	�� Microsoft 
WordPad 0	�� !	"�	�49�:+� Word-processing %��� Microsoft Word ")* save %�>��A)7�!%!;�
�A)7 ASCII format "(�(��
%!;��A)7���&�<) .SCR %	�&���	'���4*%:6�� comment )
�!
� script file 

��		�,8���123��9�0���8�+-%�	���
0��- Semicolon ( ; ) 
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 !	"�	� CAD�� &��	'"���1�� Script, AutoLISP ")* ADS  8-��	%:6��AE
�7�,�%1���! &9�0	,�(,+ 
script  !	"�	� CAD�� �8�	+�%��(,+ Script Recorder %!;�(,+�,��2���	%1�-�1����)")*(9�"0��
��	
�)6�%��&7
�:�3����1�
 Drawing 
 
0),
4��%	�%!F8(,+ Script Recorder 
0��9�
���<�1����)���%	�:6�:7)
�! 8-I��� keyboard 0	���<�C 
(9�"0��
���%	��9���	�)6�%��&7
�:�3����1�
 Drawing 4*'���,��2��!4��+��%	�4*�9���	0-<8(,+ Script 
Recorder ���
0��9�
��")*%	�&���	' Replay ����	,3
�8�(�����%	�(��
��	 
 
!������
���: (,+ Script Recorder 4*����,��2���	
��
��
�(,+ Toolbar %���0	���8�*)>�� %:	�*%����%	�

��
��4�� Toolbar, %���0	���8�*)>��(,+ script ����	��I)),:57����8� 
 

+65���	�,��2�1����)
�)
 Script 
1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools > Record Script 
� %)����!��� Toolbar ���	�!  
� :6�:7 recsript ")�+�8 Enter 

2. (,3
�����A)71�
(,+ Script ���%	�(��
��	 
3. �)6�!<J� Save 
4. 
���9�&,�
 8-:6�:7�9�&,�
)
�� keyboard (,+ Script 4*�,��2��9�&,�
")*�<��-��
���%	�:6�:7)


�� keyboard 	+�(9�"0��
(��
C ���%	�%)���
�:�3����1�
 Drawing 
 

+65���	&,�
0-<8��	�,��2� 
%)����9�1,3�(��
81,3�0�2�
8,
(���!��3 

� %)����!���%��� Tools >Stop Recording 
� %)����!��� Toolbar ���	�!  
� :6�:7 Stopscript ")�+�8 Enter 

 
+65���	 Replay (,+ Script 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Run Script 
� :6�:7�!��� Toolbar ���	�!  
� :6�:7 script ")�+�8 Enter 

2. ����8�*)>�� Record Script %)����A)7 script ���%	�(��
��	%!F8 
3. �)6����!<J� Open 

 !	"�	�4*�9�
��(�����%	��8�
���9�&,�
�!(������,��2��-��
� script 
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+65���	�,��2�(,+ Script "�� append 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Run Script 
� :6�:7�!��� Toolbar ���	�!  
� :6�:7 script ")�+�8 Enter 

2. ����8�*)>�� Record Script %)����9�%�	���
0��-'��������
 Append To Script 
3. %)����A)7���(��
��	 append 
4. �)6����!<J� Save 
5. �)6����!<J� Yes '��(��
��	%1�-�1����)�,�1����)%��� 
6. 
���9�&,�
%:����9���	�,��2�1����)(���! 

 
������������: #�����&��������

�&�� script �� $����)�
��&)���&'&���
������7�)������ CAD"�  � 
Windows Explorer  �� Double-Click �
�"5�+ script  
 
 
PROGRAMMING CAD"# 
 
 ���+65�0�2�
���%	�&���	'"���1 !	"�	� CAD�� �����	%:6�� !	"�	�%1����
��
�� 8- !	"�	�
%0)���,3���44*'��%1�-�123���4�� !	"�	�(��
C ���&���	'�9�
���,� !	"�	� CAD�� D2�
 !	"�	����
&���	'�9���
��%!;� CAD�� �>4*%!;� !	"�	�:+� LISP, ADS ")* Visual Basic for 
Application (VBA) 
 
  !	"�	� CAD�� &���	'���4*�9�
���,� !	"�	����'��%1�-�123���%:���
��
���,� !	"�	� 
AutoCAD 	+��,3
%	�&���	'�9� !	"�	����'��%1�-�123���4�� !	"�	� AutoLISP %1����
��
���8�%)- 
 8-���(��
"���1 !	"�	��,3�  !	"�	����%!;� Third-party �,� !	"�	� AutoCAD &�+�
0H�4*
&���	'�9���
���,� !	"�	� CAD�� �8�8�+- 
 
NOTE: ���	����)�������
�-��� $�������)������ CAD"� -�"���
�
�� ����!����������	�������
! �&����
	����#��"��-�� Help ���)�������
�� �	��� Developer Reference 
 
 
 
 
 
 
���$�� LISP routines 
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  !	"�	� CAD�� &���	'	,� !	"�	�49�:+� LISP programming language ")*��� 
Compatible �,� !	"�	� AutoLISP ���&�,�&�<���	�9�
��1�
 LISP Language 
� !	"�	� 
AutoCAD �,��0��-'2
%	�&���	' Load ")* Run  !	"�	� AutoLISP ���%1�-�123�%:���
��
���,�
 !	"�	� AutoCAD %1����
��
���8� 
 

+65���	 0)8 !	"�	� LISP routine 

���	
��
�����%!;�	*8,� Advanced experience level 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Load LISP or SDS Application 
� :6�:7 appload ")�+�8 Enter 
� :6�:7 Drag and Drap %1����(,+ !	"�	� CAD�� 

2. ����8�*)>�� Load Application File �)6����!<J� AppFile   
3. %)��� File ���%	�(��
��	")�+�)6�!<J� Open 
4. �)6����!<J� OK 

 

 
A. &�+�1�
��	"&8
	�-��	1�
 LISP ")* SDS ����8� Load %1����")�+ 
B. �)6�%:���%:6���A)7 LISP ")* SDS %1����
�	�-��	 
C. �)6�%:���)��A)7���'�� Hightlight 1�
4��	�-��	 
D. �)6�%:��� 0)8�A)7���'�� Hightlight 
E. �)6�%:��� Unload �A)7���'�� Hightlight 
F. %)����9�%�	���
0��-'��%����%	�(��
 Save %!;��A)7 Icadload.dfs %����%	��9�
�� Load 

")* Unload �A)70	���)6� OK 
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������������: ���	����#������)��� $���� LISP )�
���*'�*+ (load “d:/path/routine.lsp”)  �
���������	��� (���&��� 	�����������
���*�����������������
����2 Path ���"5�+) d:/ ���
#��"���+�
���0�"5�+ 
LISP, Path ���
#��)5�����+�
���0�"5�+ LISP ��� routine.lsp ���
#��"5�+ LISP �
����&��������

� $�
��� 
 

+65���	 run (,+ LISP routine 

���	
��
�����%!;�	*8,� Advanced experienced level 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Load LISP or SDS Application  
� :6�:7 appload ")�+�8 Enter 

2. ����8�*)>�� Load Application File %)����A)7 LISP 0	�� SDS ���"&8
�-��
�	�-��	
4���,3��>�)6����!<J� Load 

 
&�+�
0H���	
��
�� LISP ���%	� 0)8%1����%	�&���	'%	�-�
���8� 8-��	:6�:7����1�
 LISP �,3�C 
��		�,8
�9�&,�
 '��%	� 0)8(,+ LISP 4���8�*)>�� Load Application File %1����")�+�,����%�68�*�	123� 
0�%	�
&,
%�(����		�,8�9�&,�
0	���!8���� Prompt History  8-��	%)����!���%��� Views > Command Bar 
0	�� Views > Prompt History Windows 0	���8!<J� F2 ��� keyboard ")�+&,
%�(1���+�����"&8

(��(,+�-��
8���)��
 
 

 
 

D:\path\routine.lsp ��������8	+7���%�>��A)7 LISP, 4���,3��>������� A)%8�	7���%�>��A)7 LISP ")*4���,3��>
%!;�����1�
�A)7 LISP %	�&���	'%	�-�
��
�� LISP �8� 8-:6�:71���+�����!	��L�-��0),
(,+ C: 
 
(,+�-��
%��� '��%	� 0)8(,+ LISP %1����D2�
 LISP (,+��3���� Drawbox.lsp ")*!	��L1���+�� 
C:DRAWBOX 
��		�,8�9�&,�
0	�� Prompt History %	�&���	'%	�-�
��
�� LISP (,+��3 8-��	:6�:7 
Drawbox 
��		�,8�9�&,�
 
 
 
���$�� ADS applications 
 
 
���	%1�-� !	"�	� AutoCAD 8�+- !	"�	�G�.� C 0	�� C++ �	6.,� Autodesk 
�� ADS 
(AutoCAD Development System) D2�
%!;� API (applications programming interface) ���
�8�4,80�(,+ library %:������4*%1���!
� AutoCAD-specitic function ")*%1�-�1����) 
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D2�
%0�����,� !	"�	� CAD�� D2�
%	�%	�-�+�� SDS (Solution Development System) D2�
(,+ SDS 
%!;� !	"�	�G�.� C/C++ ���%0�����,��,� ADS 
� AutoCAD D2�
%0�����,� Script �,� AutoLISP 
%	�&���	'%	�-�
��(,+ ADS application 
� !	"�	� CAD��  8-��	 recompile (,+ source code 
 8-��	
�� SDS libraries ����8�%(	�-��+�
0�
� CD-ROM ���
��(68(,3
 !	"�	� CAD�� 0	�� !	"�	�
�,3�'��%1�-� 8- Vendor ���%!;� third-party �>(68(�� vendor �,3�%:���1�%!;�&9�0	,�%+�	7�,�1�
 !	"�	� 
CAD��  !	"�	� CAD�� �8�%(	�-�(,+�A)7 Sds.H %:����9���	�9�0�8����1�
AE
�7�,� ADS &9�0	,�(,+ 
SDS (,+ SDS &���	'	�
	,�
�&�+�1�
 AutoCAD dialog language (DCL) ���
0�(,+ ADS �9���	
�9�0�80���(�1�
�8�*)>�� 
 
 ��	�9��+��%1��
4�,� ADS compatibility 
 &6�
"	����"(�(��
�,�	*0+��
 ADS ")* SDS ���AE
�7�,�1�
 SDS 4*���9��9�0���+�� sds_ "(� 
ADS 4*���9��9�0���+�� ads_, acad_ ")* acrx_ %+��"(�AE
�7�,�1�
 SDS �8����9��9�0���+�� dig_ 
 !	"�	� CAD�� 	,��8��,3
&�
	�!"�� &�+�1��"(�(��
����C 4*"&8

0�%0>�
�	�!8���)��
 
 

 
 

��
AE
�7�,�1�
 ADS ������	�
	,��,� SDS ��� ads_msize, ads_ssgetx, ads_ssnamex, 
ads_tablet, ads_ssGetKwordCallbackPtr, ads_ssGetOtherCallbackPtr ")* 
adsw_acadDocWnd 
 
&9�0	,�	�-)*%��-8%:6��%(6� 
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� &���	'8��8�4�� Help 1�
 CAD�� 
�&�+�1�
 SDS function %1���!8�
� A)%8�	7 
\CAD��\Api\Sds 4*�� Header ")* Library files 
0�8� 

� %1���!8�
� A)%8�	7 \CAD��\Api\Dcl 
 
���$�� DCL $�%������ CAD"# 
  
  !	"�	� CAD�� &���	'	�
	,� AutoCAD DCL (dialog control language) D2�
'��
&	��
4�� !	"�	� AutoLISP %:���&	��
0���(�1�
(,+�8�*)>��%	�&���	'
���A)7 DCL �8��<��A)7
�
 !	"�	� CAD�� 
 
 
���$�� VBA (Visual Basic Application) 
 
 %	�&���	'�9���	"���10	��!	,�"(�
 !	"�	� CAD��  8-
�� Visual Basic for 
Applications (VBA) ���"&8
�-��
�%���1�
 CAD��  !	"�	� CAD�� &���	'���
0�%	�%1�-� 
application 123���
��
��
� !	"�	��8� 

 
+65���	 run (,+ VBA macro 

���	
��
�����%!;�	*8,� Advanced experience level 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Visual Basic > Macro> 
� :6�:7 vbarun  ")�+�8 Enter 

2. ����8�*)>�� Run CADian VBA Macro :6�:7���� VBA Macro ���(��
��	")�+�)6�
!<J� Run %	�&���	'&	��
, )�")*"���1(,+ VBA Macro �8�����8�*)>����3 

 
+65���	"���1(,+ VBA Macro 

���	
��
�����%!;�	*8,� Advanced experience level 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Tools > Visual Basic > Visual Basic Editor 
� :6�:7 vba ")�+�8 Enter 

2. 
�� !	"�	� Microsoft Visual Basic Editor %1�-�0	��"���1 VBA Macro 
 
&9�0	,�	�-)*%��-8%:6��%(6� 

� &���	'8��8�4�� Help �,3

� !	"�	� VBA editor help ")*
� help 1�

 !	"�	� CAD��  

� &���	'8��8�4��0�,
&��0	��%��&�	����56��-'2
+65���	
�� !	"�	� VBA 



��������	
��
�� CAD��  

 
 
���$�� Digitizer table 
 
  !	"�	� CAD�� &���	'	�
	,� tablet ��� compatible �,��8	%+�	7���%!;� TobletWorks ���
(,+ Tablet overlay �+�
��
�� &9�0	,�+65���	(68(,3
 tablet driver ")*��	
��!<J�(��
C 
�(,+ Digitizer 
tablet &���	'@2�.��8�4��������1�
(,+ Digitizer 

 
&����!�,����!	��L%����%	�
���9�&,�
 Tablet 

� Configure %!;���	 Map (,+ Tablet overlay %!;���	�9�0�8��	%	�-�
���9�&,�

1�
 !	"�	� CAD�� 4��(,+ Tablet overlay 

� Calibrate �9�0�8(9�"0��
0	��4<8��(,+ Tablet ���%!;�(9�"0��
 coordinate )

�!
� Drawing 

� Tablet ON/OFF %!;���	!F8/%!F8��	
��
��1�
(,+ Tablet '��%	�(��
��	
��
��
(,+ Tablet %	�(��
!	,�%!;� 0�8 OFF 

 
��	 configure (,+ Tablet 
�������%	�4*%	6���9���	 configure (,+ Tablet 
0�%)����(,+ Tablet overly 
0�(�9��+��"I��:)�&(6�
1�
(,+ Tablet ")*0,�(,+ Tablet overly 
0�(	
�,�(,+ Tablet  '��%	������"I��:)�&(6�
0�%	�
0,�(,+ Overly hole (��(,+0�<8����-��
� Tablet 
 
 !	"�	� CAD�� %(	�-���� configure ���%!;���� default &9�0	,�1��81�
 Tablet ���%!;� 12” 
by 12” '��%	�-��	,���� default %:���%!;���	�9�0�8�9�&,�

� grid ���'��(��
 "(�'��(,+��� default 

������8�
� Tablet 1�
%	�(��
�9���	 configure 
0������	,3
4���,3�%	��9�0�8(�����%	�(��
��	 
 
+65���	�9�0�8(,+ Tablet &9�0	,���	�9�%!;� Menu input 

1. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� %)����!���%��� Settings > Tablet > Configure 
� :6�:7 tablet ")�+�8 option %!;�"�� configure ")�+�8 Enter 

2. %)����9�1,3�(��
81,3�0�2�
8,
(���!��3 
� '��(,+ Tablet %	�%!;� 12” by 12” 
0�%)��� No %:���-��	,���� default ")*4�

1,3�(����	�9� Configure 
� '��%	�(��
��	�9�0�8%�

0�%)��� Yes ")*�9�(���!-,
1,3�(����� 3 

3. �)6�(,+ Tablet pointer ���(9�"0��
D��-���-��  8-+�
0,�
0�(	
�,�(,+  ���(9�"0��
��� 
1 
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4. �)6�(,+ Tablet pointer ���(9�"0��
D��-���-)��
  8-+�
(,+0,�
0�(	
�,�(,+  ���
(9�"0��
��� 2 

5. �)6�(,+ Tablet pointer ���(9�"0��
1+����-)��
  8-+�
0,�
0�(	
�,�(,+  ���(9�"0��
��� 
3 

6. �)6�(,+ Tablet pointer ���(9�"0��
D��-���-)��
1�
:�3����1�
 Work space area  8-
0,�"�+1�
(,+ Pointer 
0�(	
�,�(,+  

7. �)6�(,+ Tablet pointer ���(9�"0��
1+����-�� 1�
:�3���� Work space area  8-0,�
"�+1�
(,+ Pointer 
0�(	
�,�(,+  

 

 
(9�"0��
(��
C 1�
��	�)6�(,+ Tablet pointer 

 
+65���	%!F8/!F8 Tablet  0�8 
%)����9�1,3�(��
81,3�(��0�2�
(���!��3 

� %)����!���%��� Setting >Tablet > Tablet On 0	�� Tablet Off 
� :6�:7 Tablet ")�+%)��� Option %!;� On 0	�� Off 
� �8!<J� F4 %:����9���	 %!F8/!F8 
� ��� statusbar �9���	 bouble-click %:����9���	 %!F8/!F8 

 
��	 Calibrate (,+ Tablet 
%	�(��
�9�0�84<8�-��
���- 2 4<8 &9�0	,���	�9� Calibrate '2
�-��
�	�>(����	�9�0�8����+�� 2 4<8 4*
�9�
0�(9�"0��
(��
C '��(��
���123�	*0+��
(,+ Tablet ")*(,+ Screen point ��	�9�0�84<8���%:6��123�4*
�9�
0���	 calibrate )*%��-8���123�")*4*%!;�!	* -��7
���	%1�-� Drawing ���%!;�G�:'��-��

����@ 
 
Understanding transformation types 
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  Coordinate ���"&8
I)
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1. Coordinate X0, Y0, Z0 
2. Coordinate X0, Y5, Z0 
3. Coordinate X5, Y5, Z0 
4. Coordinate X5, Y0, Z0 
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 ��	 customize (,+ Tablet interface 
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Customizing the Tablet Interface 
 


